
Exercício 1 – Distritos e Sistema Metroferroviário da RMSP 

 

Neste exercício com o uso de software SIG, serão carregados, em um banco de dados, de uso 

do aluno, camadas de informação, com os mapas dos distritos, dos municípios, da Região 

Metropolitana de São Paulo (RMSP), e do seu sistema metroferroviário, em especial as 

estações. Esses dados serão usados em exercícios subsequentes. 

Parte I – Criar mapa de distritos da RMSP num banco de dados GeoPackage, com o uso do 

software QGis. 

(1) Mapa dos distritos da RMSP 

Buscar e baixar o arquivo DistrRMSP.zip, do Repositório da página da disciplina no Tidia 

 Notas de Aula e exercícios: > dados da RMSP para exercícios > 

 clicar com o botão direito do mouse () e selecionar a opção ‘Salvar link como...’ 

  Distritos da RMSP - Córrego Alegre - UTM 23S (Centro de Estudos da 

Metrópole), sob os anos 2005 – 2011 

Trata-se do mapa de distritos, produzido pelo Centro de Estudos da Metrópole – CEM, da USP. 

(2) Descompactar os arquivos numa pasta de trabalho, por exemplo, sistema metroferroviario. 

 Clicar com o botão direito sobre o arquivo ZIP e descompactar com o Windows 

   DistrRMSP.zip > Extrair tudo... 

 ou com o software de compactação/descompactação que estiver instalado 

  Por exemplo, o 7Zip (freeware) 

O pacote se desdobra em seis arquivos no formato ESRI shapefile. 

 CEMdist.dbf dados dos distritos 

 CEMdist.prj sistema de coordenadas dos distritos 

 CEMdist.sbn (não obrigatório) de indexação espacial* 

 CEMdist.sbx (não obrigatório) de indexação espacial* 

 CEMdist.shp representação geométrica de cada distrito 

 CEMdist.shx correspondência entre cada representação geométrica, do arquivo SHP, 

e seus respectivos dados no arquivo DBF 

 * esses arquivos não serão aproveitados no banco de dados a ser criado – caso que a 

indexação espacial será refeita dentro dele. 

(3) Abrir o arquivo PRJ para saber do sistema de coordenadas do shapefile, com um editor de 

texto simples, por exemplo, o aplicativo Bloco de Notas 

 Trata-se o sistema de projeção intitulado ‘Corrego_Alegre_UTM_Zone_23S’, ou seja, 

da Projeção UTM (Universal Transversal Mercator) Zona 23 Sul, sobre o Datum ‘Córrego 

Alegre’, não mais o oficialmente em uso no Brasil. 

 O Datum oficialmente em uso no Brasil é o SIRGAS 2000* 



* também, por questão prática, dependendo da aplicação, faz-se uso do WGS84. 

(4) Executar o software QGis e configurar o sistema de coordenadas para a projeção UTM 23S 

sobre o Datum ‘Corrego Alegre 1970-72’ para referenciar o mapa dos distritos do CEM. 

Executar o software QGis instalado, sendo altamente recomendável o uso de uma versão 

estável (long-term), e não a última versão, em geral, ainda sob testes de funcionamento, 

 por exemplo, foi usada a versão 3.28 – Firenze, na elaboração deste texto. 

 Project > New 

(4.1) selecionar o sistema de projeção do projeto 

Project > Properties > CRS 

Em Filter, buscar ‘Corrego Alegre’ – e observar as diversas opções indicadas em Predefined 

Coordinate Reference Systems 

 minimizar o grupo Geographic Coordinate Systems, deixando aberto o grupo Projected 

Coordinate Systems 

 da lista, selecionar o sistema de projeção 

  Corrego Alegre 1970-72 / UTM 23S EPSG:22523 

 [Apply] 

 [OK] 

Observar no canto inferior esquerdo da tela, a indicação [EPSG:22523]. 

(4.2) referenciar o shapefile no projeto 

 Layer > Add Layer > Add Vector Layer… 

 Source type 

  (*) File 

 Encoding 

  Automatic 

 Source – Vector datasets 

  […] e navegar até a pasta de trabalho e selecionar o arquivo CEMdist.shp 

 [Add] 

 [Close] 

 Observar o mapa dos distritos da RMSP 

(4.3) verificar o sistema de coordenadas 

  CEMDist > Properties > Source  

  verificar em Assigned Coordinate Reference System que se trata também do 

EPSG:22523, em concordância do indicado para o Project 

 [Close] 

(5) Verificar a codificação (Encoding) para caracteres acentuados 

  CEMdist > Open Attribute Table 



  observar na coluna nome que a acentuação e uso de cê-cedilha estejam 

corretos, ou seja, se o 'Encoding' automático funcionou, caso contrário haveria de alterar a 

codificação para a correta, 

 no caso, ‘ISO-8859-1’ (Latin-1), o que pode ser verificado ou alterado, ao clicar com o 

botão direito () do mouse sobre o nome da camada e selecionar: 

   CEMdist > Properties... > Source 

   Data source encoding 

    ISO-8859-1 

   [Apply] e [OK] se necessário, senão, apenas [Cancel] ou [X] 

(6) Salvar o projeto em sua pasta de trabalho, como AUT5826 - Exercicio 1 

 Project > Save 

(7) Confrontar os atributos alfanuméricos, seus valores e tipos de dados: 

  CEMdist > Properties... > Fields 

 e 

  CEMdist > Open Attribute Table 

(7.1) os campos IBGECOD, SIGLA, NOME, NOMECAPS identificam univocamente os distritos, 

não havendo necessidade para os campos numéricos ID e CEMCOD (a não ser, no caso deste 

último, que houvesse tabela adicional de dados dos distritos, fornecida pelo CEM, com essa 

codificação de chave primária). 

(7.2) o campo IBGEPOP00, se refere à população do Censo de 2000; os valores de AREA podem 

ser recalculados a partir da geometria dos polígonos representativos desses distritos, ou obtida 

de tabelas do IBGE; e a DENSIDADE pode ser recalculada a partir de dados corretos e/ou 

atualizados. 

(7.3) o campo IBGECOD está definido como numérico Inteiro de 64 bits e doze dígitos. Trata-se 

da codificação dos distritos, de 7 dígitos para o município, seguido de 2 dígitos para o distrito. 

Não há razão para ser definido como numérico, por não ser usado em cálculos matemáticos. 

(8) Fazer as alterações na tabela de atributos da camada acima indicadas. 

Selecionar a camada CEMdist com um clique do mouse e depois, selecionar: 

 Processing > Toolbox > Vector table >  Refactor fields (com duplo clique ) 

 Input Layer 

  CEMdist [EPSG:22523] 

 Refactored 

  [...] 

  [Create temporary layer] 

 Fields Mapping 



  Selecionar os atributos ID, CEMCOD, AREA, IBGEPOP00 e DESNIDADE (um de 

cada vez, ou conjuntamente) e excluir com o botão identificado por [Delete selected field] – 

usar a tecla [Ctrl] para selecionar mais de um; 

  Selecionar o atributo IBGECOD e alterar o seu Type e Length respectivamente 

para Text (string) e 9 (nove) 

 [v] Open output file after running algorithm 

 clique no botão [Run] 

 depois que executar e adicionar a camada recém criada à lista de camadas, terminar 

com [Close] 

 Observar a camada temporária, de nome Refactored, ou similar, na lista de camadas do 

projeto. 

(9.1) Verificar a tabela de atributos, e seus valores, da camada temporária recém-definida 

  Refactored > Open Attribute Table 

[9.2] Verificar se o CRS aparecer como inválido, caso em que os ícones representativos das 

estações não são exibidos no mapa, indicar o correto em: 

  Refactored > Properties > Source 

  Assigned Coordinate System 

   EPSG:31983 SIRGAS 2000 / UTM 23S 

 É importante fazer isso, antes de armazenar esses dados no BD GeoPackage. 

(10) Aproveitar para salvar o referido projeto, com as alterações feitas até o momento 

 Project > Save 

(11) Carregar os dados da camada Refactored para um banco de dados GeoPackage, 

aproveitando converter o sistema de coordenadas, do Datum Corrego Alegre para o SIRGAS 

2000, atualmente o oficialmente em uso no Brasil, mantendo o sistema de projeção UTM 23S. 

  Refactored > Export > Save Features As... 

Na tela, ‘Save Feature As’ configurar a exportação da camada para o GeoPackage: 

 Format 

  GeoPackage 

 Fine name 

  navegar até a pasta de trabalho em uso e indicar o nome do GeoPackage a ser 

criado, no caso: 

  Exercicio_1 

  [Save] 

 Layer name 

  DistritosCEM 

 CRS 

  clicar no botão indicado como ‘Select CRS’ 



  e em Filter, buscar ‘SIRGAS 2000’ – e observar as diversas opções indicadas em 

Predefined Coordinate Reference Systems 

  minimizar o grupo Geographic Coordinate Systems, deixando aberto o grupo 

Projected Coordinate Systems 

  da lista, selecionar o sistema de projeção 

   SIRGAS 2000 / UTM 23S EPSG:31983 

  [OK] 

 [v] Extent (current layer) 

  Clicar no botão [Current Layer Extent], ou seja, o retângulo mínimo que 

envolve a RMSP 

 Layer Options 

  SPATIAL_INDEX 

   YES – para criar indexação especial 

 [v] Add saved layer to map 

 [OK] 

 São apresentadas duas opções de conversão – usar a default de 2 m de acurácia (não 

parece haver muita diferença nas descrições). 

 Também, no processo, a codificação é alterada para a padrão UTF-8 

(11.1) Verificar se a acentuação está correta e o sistema de coordenadas da camada recém 

criada, de nome DistritosCEM no GeoPackage Exercicio_1, que aparece na lista como 

‘Exercicio_1 – DistritosCEM’. 

(11.2) Renomear a camada na lista como apenas DistritosCEM 

  Exercicio_1 – DistritosCEM > Rename Layer 

(11.3) Curiosidade: o município Mogi das Cruzes está escrito como Moji das Cruzes na tabela 

de atributos do arquivo obtido do CEM. 

(12) Remover cada camada, em formato Shapefile, originalmente referenciada do projeto 

  Refactored > Remove Layer... 

  CEMdist > Remove Layer ... 

(13) 

Alterar o sistema de coordenadas do projeto, 

 de Corrego Alegre 1970-72 / UTM 23S para SIRGAS 2000 / UTM 23S 

(14) 

Salvar novamente o projeto para refletir as alterações efetuadas. 

 

Parte II – Mapas do sistema metroferroviário da RMSP 

O sistema metroviário da RMSP está em constante evolução, por isso há de se acessar o 

arquivo mais recente, ou seja, do seu sítio eletrônico. 

(15) Acessar o site do Geosampa 



https://geosampa.prefeitura.sp.gov.br/PaginasPublicas/_SBC.aspx 

(16) Fazer download das estações e linhas (existentes) do sistema metroferroviário, em 

formato Shapefile, do grupo de camadas Transporte, em 

 Camadas > Transporte > Trem > Trem Metropolitano – Estação 

 Camadas > Transporte > Trem > Trem Metropolitano – Linha 

 Camadas > Transporte > Metrô > Metrô – Estação 

 Camadas > Transporte > Metrô > Metrô - Linha 

(17) 

Cada conjunto vem baixado na forma de um arquivo ZIP 

 Há de se descompactar os arquivos na pasta de trabalho, criada anteriormente, 

'sistema metroferroviario'. 

(18) Verificar no arquivo, indicativo do sistema de coordenadas usado, PRJ, que se trata da 

projeção UTM 23S, sobre o Datum SIRGAS 2000, atualmente o oficialmente em uso. 

(19) No software SIG, QGis, abrir o projeto, anteriormente salvo, denominado 'AUT5826 – 

Exercicio 1', e, em seguida, abrir todos os shapefiles, se possível, de uma só vez, a partir da 

seleção: 

 Layer > Add Layer > Add Vector Layer ... 

  Source Type 

   (*) File 

  Encoding 

   Automatic 

  Source - Vector Dataset(s) 

   [...] (Browse) 

    selecionar, 'estacao_metro_v2.shp', depois, sempre com a tecla 

'Ctrl', selecionar também 'estacao_term_v2.shp', 'linha_metro_v4.shp', e 'linha_trem_v2.shp' 

(apenas os de terminação SHP) 

    e clicar [Open] 

  [Add] (Add selected layers to map) 

  [Close] 

(20) Na lista de camadas (Layers) do software, clique com o botão direito () do mouse sobre o 

nome da camada 'estacao_trem_v2' e selecione 'Open Attribute Table' 

 para verificar, na coluna 'nm_estacao', se a acentuação está correta, ou seja, se o 

'Encoding' automático funcionou, caso contrário haveria de alterar a codificação de cada 

camada para a correta, 

 no caso, 'Windows-1252', o que pode ser verificado ou alterado: 

   estacao_trem_v2 > Properties... > Source 

   Data source encoding 'Windows-1252' (Latin 1 / Western European) 

   [Apply] e [OK] se necessário, senão, apenas [Cancel] ou [X] 

(21) 



Abrir novamente a tabela de dados da camada 'estacao_trem_v2' e verificar que as colunas 

'cd_identif', 'cd_identi0', 'cd_situaca', e 'cd_identi1' exibem números de ponto flutuante, que, 

na realidade seriam números inteiros 

 Posicione o apontador do mouse em cada uma dessas colunas e observe que os seus 

tipos de dados estão como Real(32,15), ou seja 32 dígitos, sendo quinze para a parte 

fracionária 

 Também, 'cd_tipo_tr' exibe números inteiros e seu tipo de dados está como Integer(9), 

inteiro de nove dígitos, um tanto exagerado. 

 Entretanto, não há razão para haver atributos numéricos, se não forem usados em 

cálculos matemáticos.  

(22) Esses atributos podem ter seus tipos alterados para texto (string), mas há de se considerar 

a finalidade de cada um. 

Da observação dos dados das estações dos arquivos estacao_trem e estacao_metro, pode-se 

concluir o que segue, a respeito dos atributos de codificação numérica: 

 cd_identif numeração dos pares estação-linha, de 1 a 94 no caso do 

estacao_metro, de 564 a 659 no caso do estacao_trem (96 pares); trata-se de identificador 

único, mas, ao que tudo indica, sem correspondência com outros dados; será substituído por 

fid quando da importação no banco de dados GeoPackage; 

 cd_identi0 numeração da operadora – 1: METRO, 2: CPTM, 3: VIAQUATRO, e 

6: VIAMOBILIDADE, mas já existe o atributo nm_empresa com esse papel; 

 cd_situaca em todos os casos, está como 1, ou seja, OPERANDO, o que é indicado 

pelo atributo tx_situaca – portanto pode ser considerado redundante; 

 cd_identi1 número da linha, correspondente a designação pela cor, do atributo 

nm_linha_m; 

 cd_tipo_tr 1, no caso do estacao_metro, e 2, para estacao_trem; 

O atributo tx_situa também pode ser considerado redundante, visto todos os pares estação-

linha desses arquivos estarem operacionais; O mesmo no caso do atributo sg_fonte_o. 

(22.1) Com a referida camada, apontada na lista de camadas, selecionar: 

 Processing > Toolbox > Vector table >  Refactor fields (duplo clique) 

 Input Layer 

  estacao_trem_v2 

 Refactored 

  [...] 

  [Create temporary layer] 

 Fields Mapping 

  Selecionar os atributos cd_identif, cd_identi0, sg_fonte_o, cd_situaca, e 

tx_situa (um de cada vez, ou conjuntamente) e excluir com o botão identificado por [Delete 

selected field] – usar a tecla [Ctrl] para selecionar mais de um; 



  Selecionar o atributo cd_identi1 e alterar o seu Type, Length, e Precision, 

respectivamente, para Text (string), 2 (dois) e 0 (zero) 

  Selecionar o atributo cd_tipo_tr e alterar o seu Type, Length e Precision, 

respectivamente, para Text (string) e 1 (dois), e 0 (zero) 

[v] Open output file after running algorithm 

 clique no botão [Run] 

 depois que executar e adicionar a camada recém criada à lista de camadas, terminar 

com [Close] 

(22.2) Abrir a tabela de atributos da camada temporária recém-criada e verificar se as 

alterações foram bem sucedidas. 

[22.3] Verificar se o CRS aparecer como inválido, caso em que os ícones representativos das 

estações não são exibidos no mapa, indicar o correto em: 

  Refactored > Properties > Source 

  Assigned Coordinate System 

   EPSG:31983 SIRGAS 2000 / UTM 23S 

 É importante fazer isso, antes de armazenar esses dados no BD GeoPackage. 

(22.4) Salvar o projeto, para preservar as alterações feitas 

(23) Carregar a camada temporária no banco de dados GeoPackage 

  Refactored > Export > Save Features As... 

Na tela, ‘Save Feature As’ configurar a exportação da camada para o GeoPackage: 

 Format 

  GeoPackage 

 Fine name 

  navegar até a pasta de trabalho em uso e indicar o nome do GeoPackage a ser 

criado, no caso: 

  Exercicio_1 

  [Save] 

 Layer name 

  estacao_trem 

 CRS 

  SIRGAS 2000 / UTM 23S EPSG:31983 

 [v] Extent (current layer) 

  Clicar no botão [Current Layer Extent], ou seja, o retângulo mínimo que 

envolve a RMSP 

 Layer Options 

  SPATIAL_INDEX 

   YES – para criar indexação especial 

 [v] Add saved layer to map 

 [OK] 



(23.1) Se necessário, renomear, de’ Exercicio 1 – estacao_trem’ para, apenas, ‘estacao_trem’ 

(24) Abrir a tabela de atributos da camada recém-criada 'estacao_trem' e verificar se as 

alterações foram bem sucedidas, caso em que a camada original 'estacao_trem_v2' pode ser 

removida do projeto, assim como a temporária: 

  Estacao_term_v2 > 'Remove Layer...', e confirmar 

  Refactored > 'Remove Layer...', e confirmar 

(25) Salvar novamente o projeto 

(26) Fazer o mesmo com a camada 'estacao_metro_v2', para a criação da camada 

'estacao_metro' no mesmo banco de dados Geopackage 'Exercicio_1' 

 Observar, em todas as camadas, que os nomes dos atributos estão limitados a dez 

caracteres. Num ESRI Shapefile, os dados estão num arquivo no formato DBF do software 

dBase (da empresa Ashton-Tate), de 1979. 

(27) 

Abrir a tabela de atributos da camada 'estacao_metro' recém-criada e verificar se as alterações 

foram bem sucedidas, caso em que a camada original 'estacao_metro_v2' pode ser removida 

do projeto 

  estacao_metro_v2 > 'Remove Layer...', e confirmar 

(28) Salvar novamente o projeto 

(29) Em ambos casos acima, o atributo fid é o identificador único, criado quando do 

carregamento dos dados de uma camada no banco de dados GeoPackage Exercicio_1. Chaves 

candidatas também seriam as composições: 

 (nm_estacao, cd_identi1) e (nm_estacao, nm_linha) 

 

Parte III – Extra – ‘Visite Nossa Cozinha (Município de São Paulo - Lei Municipal 11.617/1994)’ 

O banco de dados GeoPackage é na realidade um encapsulamento parcial de um banco de 

dados Sqlite. 

(30) Fazer uma cópia do arquivo Exercício_1.gpkg e renomear essa cópia como Exercicio_1.db, 

ou seja, alterar a terminação do arquivo de GPKG para DB. 

 Exercicio_1.gpkg BD GeoPackage 

 Exercicio_1.db BD sqlite (renomeado) 

(31) O banco de dados no formato Sqlite pode ser acessado com um aplicativo de interface de 

banco de dados como, por exemplo, o Sqlite Express / Sqlite Studio, em: 

 https://sqlitestudio.pl/ 

 Há uma versão inicial, que ainda funciona, e pode ser baixada de: 

  https://aut5826.fau.usp.br/sqlite/SqliteExpressSetup_v0.1.0.msi 

https://sqlitestudio.pl/
https://aut5826.fau.usp.br/sqlite/SqliteExpressSetup_v0.1.0.msi


 Juntamente com uma DLL (dynamic link library), necessária para o seu funcionamento, 

que deve ser copiada numa das pastas de Path* do Usuário ou na própria pasta aonde o 

software for instalado: 

 https://aut5826.fau.usp.br/sqlite/SQLite.Interop.dll 

* digitar env no menu Iniciar do Windows 

 Editar as variáveis de ambiente do sistema 

 [Variáveis de ambiente] 

 Variáveis de usuário para <nome do usuário> 

  Path 

  Editar 

   [Novo} 

   Entrar o caminho até a pasta onde se encontra a DLL, por exemplo: 

    C:\sqlite3 

   [OK] 

Os passos a seguir têm por base o uso dessa versão. Versões atualizadas não foram ainda 

testadas, mas devem funcionar de maneira similar. 

(32) Conectar ao BD Sqlite 

 Connect to Database 

  navegar até a pasta de trabalho e abrir o arquivo Exercicio_1.db 

(32.1) A lista de bancos de dados exibe o banco de dados, suas tabelas e vistas (views), esta 

última não contém elementos. 

 É possível criar objetos de banco de dados no BD Sqlite, mas estes podem não ser 

entendidos como parte da definição de um BD GeoPackage e o próprio arquivo pode ser 

interpretado como estando corrompido pelo QGis ou outro software que tente acessar o 

GeoPackage alterado como Sqlite. 

(32.2) No caso, a lista indica as tabelas de dados esperadas: 

 DistritosCEM 

 Estacao_metro 

 Estacao_trem 

Mas, há outros que não são vistos, por fazerem parte do encapsulamento do GeoPackage. 

Trata-se de dados escondidos propositalmente dos usuários, pelos aplicativos de criação de 

dados e de manipulação de dados de um GeoPackage, mas que são visíveis quando do uso de 

um aplicativo de criação e manipulação de dados de um banco de dados Sqlite. 

Pode-se explorar os elementos originalmente conhecidos 

(33) 

Expandir a tabela DistritosCEM e seus subitens: 

https://aut5826.fau.usp.br/sqlite/SQLite.Interop.dll


 [-] DistritosCEM 

  [-] Columns 

   fid (INTEGER, not null, pk) 

   geom (VARCHAR, null) 

   IBGECOD (VARCHAR(9), null) 

   SIGLA (VARCHAR(5), null) 

   NOME (VARCHAR(30), null) 

   NOMECAPS (VARCHAR(3), null) 

   MUNSIGLA (VARCHAR(8), null) 

   MUNNOME (VARCHAR(30), null) 

       Relations 

       Indexes 

  [-] Triggers 

   rtree_DistritosCEM_geom_insert 

   rtree_DistritosCEM_geom_update1 

   rtree_DistritosCEM_geom_update2 

   rtree_DistritosCEM_geom_update3 

   rtree_DistritosCEM_geom_update4 

   rtree_DistritosCEM_geom_delete 

   trigger_insert_feature_count_DistritosCEM 

   trigger_delete_feature_count_DistritosCEM 

 

(33.1) o atributo fid foi criado quando do carregamento dos dados para o BD GeoPackage, e 

definido como chave primária (PK) – portanto não aceita ausência de valor (not null); 

(33.2) não são definidas chaves estrangeiras (foreign keys), ou seja, associações entre 

instâncias desta tabela e instâncias de outras tabelas, por meio de seus atributos. 

(33.3) não há indexação (indexes) com base em outros atributos, que não o da PK, fid. 

(33.4) há uma série de gatilhos (triggers), acionados quando se insere uma nova instância em 

DistritosCEM, ou se ocorrem alterações em sua geometria, ou ainda, no caso de remoção de 

uma instância. 

(34) Uso de linguagem de manipulação de dados – queries em SQL 

 New Query 

  Na tela indicativa da query a criar, digitar: 

  Select * from DistritosCEM; 

 [Run] 

 O resultado aparece logo abaixo. O uso do caractere asterisco (*) equivale dizer que se 

deseja listar todos os atributos. 

(34.1) Há um atributo, quase despercebido quando da criação desta camada no QGis, geom. 

Trata-se de denominação default, não citada quando da exportação dos dados dos distritos 

para o GeoPackage, assim como o fid. 



 pode-se clicar sobre os dizeres (viewcontent) de uma dessas instâncias para visualizar 

seu conteúdo, exibido em uma janela a parte, e identificado oficialmente como do tipo varchar, 

mas que, de fato, é um ‘blob’ – binary large object. 

 Trata-se da codificação da geometria do distrito em questão, exibida integralmente em 

formato hexadecimal, difícil de ser interpretado, mesmo conhecendo sua estrutura de dados. 

(34.2) a query pode ser salva externamente ao BD como na forma de um arquivo de texto, para 

poder ser usada posteriormente no BD ou documentação do sistema. 

(35) Uso de linguagem de definição e de manipulação de dados – queries em SQL 

  rtree_DistritosCEM_geom_insert > Edit 

 Na tela de expressões pode-se visualizar as expressões: 

  DROP TRIGGER IF EXISTS rtree_DistritosCEM_geom_insert 

  CREATE TRIGGER "rtree_DistritosCEM_geom_insert" AFTER INSERT ON 

"DistritosCEM" WHEN (new."geom" NOT NULL AND NOT ST_IsEmpty(NEW."geom")) BEGIN 

INSERT OR REPLACE INTO "rtree_DistritosCEM_geom" VALUES (NEW."fid", 

ST_MinX(NEW."geom"), ST_MaxX(NEW."geom"), ST_MinY(NEW."geom"), 

ST_MaxY(NEW."geom")); END 

 A primeira remove o próprio gatilho, seguida de criação e execução de novo gatilho, 

disparado quando da inserção de uma nova instância, ou seja, um novo distrito, na camada. 

 Esta segunda expressão faz a inclusão do retângulo envolvente mínimo de um novo 

distrito, dado pelas funções ST_MinX(), STMaxX(), ST_MinY() e ST_MaxY() sobre a geometria 

NEW.”geom” da nova instância NEW, identificada pela sua chave primária NEW.”fid”. 

 Rtree é a forma de indexação espacial adotada no GeoPackage, cujos detalhes são 

escondidos de quem usa um software SIG, como o QGis. 

(36) Pode-se explorar as demais tabelas, e seus elementos, no BD Sqlite, escondidas para quem 

usa o correspondente GeoPackage. 


